WorldWideScripts.net Delivering the best Add-Ons in more than 37 languages.

中文(简体), English, हिन्दी/हिंदी, Español/Castellano, العربية, Русский язык, Français, 中文 (台灣), বাংলা, Bahasa Indonesia, اردو, Português, Deutsch, Bahasa Melayu (بهاس ملايو‎), 日本語 (にほんご), فارسی, Italiano, తెలుగు, Türkçe, ગુજરાતી, Język polski/polszczyzna, Tiếng Việt, ಕನ್ನಡ, Українська мова, ไทย
PHP Scripts / Miscellaneous

Advanced Permission System

— Add -On per WorldWideScripts.net

Rep les nostres RSS per estar al dia!

Nou! Segueix-nos com vulguis!


Advanced Permission System - CodeCanyon Item for Sale

Ads

Ad: Bluehost hosting

Seguiu Envato Veure vídeo de vista prèvia

Actualitzat a la versió 1.2

El Sistema de Permís avançada (APS) li permet assegurar el seu lloc web o parts d'ella.

Vostè pot protegir el seu lloc web amb l'addició de només dues línies de codi en la pàgina que voleu protegir.
Vostè pot assegurar qualsevol pàgina i controlar l'accés des del panell d'administració intuïtiva i fàcil d'utilitzar.
Pot registrar un nombre il·limitat de comptes d'usuari i crear grups il·limitades amb diferents permisos.

El sistema es basa en grups de permisos. Pot registrar usuaris i afegir als grups. Si un usuari vol accedir a una pàgina protegida se li demanarà per iniciar sessió. Si el compte està activa i està en almenys en un grup amb permís per accedir a la pàgina actual que va a veure el contingut protegit, en cas contrari, veureu un missatge d'error.

Heus aquí un petit esquema / exemple del que el sistema:

TEVIOR PROTECCIÓ LLOR GRUPS PERMISOS WEB

Característiques

  • Pàgines il·limitades per protegir
  • Nombre il·limitat d'usuaris per registrar-
  • Grups il·limitades per afegir
  • Hi ha tres tipus de comptes d'usuari (super administrador, administradors i usuaris regulars)
  • Estats de comptes activades, no activades i prohibits
  • URL de retorn per defecte després de Entrada
  • Tornar Custom URL per a cada pàgina
  • Missatge d'error personalitzat
  • Usuari autoregistre (opcional, si està activada en configuracions)
  • Contrasenya
  • Panell intuïtiu i administració fàcil d'usar
  • Orientada a objectes panell d'administració
  • Instal·lador web

Requeriments

El sistema requereix PHP 5. * i MySQL 5. * executin.

Historial de canvis

  • 1.2.1
    • Fix: Error tipogràfic en l'instal·lador crea constant malament en el config.php amb nom DEFAULT_DEFAULT_RETURN_URL lloc de DEFAULT_RETURN_URL
  • 1.2
    • Actualització: Windows Compatibilitat servidors
    • Fix: S'ha corregit un problema de compatibilitat entre les diferents configuracions de servidor per a la funció php echo
    • Afegit: funcionalitat contrasenya perduda
    • Afegit: Usuaris acte registre
    • Afegit: Multi protecció d'inici de sessió (evitar que diversos usuaris puguin accedir d'un compte alhora)
    • Afegit: base de dades d'actualització a la versió 1.2. Per actualitzar la base de dades que ha de carregar carpeta d'actualització i obrir-lo en el vostre navegador (Exemple: Aneu a www.domain.com/aps/update
    • Afegit: config-ejemplo.php - fitxer de configuració exemple ben documentat
  • 1.1
    • Afegit: formulari d'accés en línia (per protegir part de la seva pàgina web)
    • Actualització: En primer lloc l'usuari administrador (d'instal·lador) és super administrador
    • Actualització: Admin no pot canviar qualsevol altra condició d'administrador
    • Actualització: Admin no pot afegir l'usuari admin
    • Actualització: Admin no pot eliminar l'usuari admin
    • Actualització: Només súper administrador pot afegir i eliminar usuaris administradors
    • Actualització: Només súper administrador pot canviar l'estat d'administrador
    • Actualització: l'estat de compte d'administrador i super administrador no importa per a inici de sessió
    • Actualització: Millora de la lògica del codi
  • 1.0 - Versió inicial

Descarregar
Altres components d'aquesta categoriaTots els components d'aquest autor
Comentaris dels clientsPreguntes freqüents i respostes

Propietats

Creat:
24 mar 12, última actualització

Alta Resolució:
no

Navegadors compatibles:
IE6, IE7, IE8, IE9, IE10, EI11, Firefox, Safari, Opera, Chrome, Arxius Inclosos

Paraules clau

comerç, electrò, nic, comerç, electrò, nic, tots els articles, accé, s, comptes, avanç, at, control, grups, bloqueig, pà, gines, permisos, seguretat, sistema, els usuaris